VersionConstraint.compatibleWith constructor

VersionConstraint.compatibleWith(
  1. Version version
)

Creates a version constraint which allows all versions that are backward compatible with version.

Versions are considered backward compatible with version if they are greater than or equal to version, but less than the next breaking version (Version.nextBreaking) of version.

Implementation

factory VersionConstraint.compatibleWith(Version version) =>
    new CompatibleWithVersionRange(version);